• Welcome to the Contour Enthusiasts Group, the best resource for the Ford Contour and Mercury Mystique.

    You can register to join the community.

Drivability Issues

Wee_Todd

Be Gentle I'm New Here
Joined
Sep 10, 2022
Messages
3
Location
Ontario, Canada
Hey everyone. Having an issue with lumpy (rough) idle and stalling when stopped or low speed maneuvers such as parking. Idle speed is about 700 RPM.

The car is a new to me car, 1999 SVT. It has 89k KM on it. I noticed the car was a little rough at idle when I first drove it home and decided to try and correct the problem. Was showing about 700 RPM on the tach. I ran some injector cleaner through it, and changed the spark plugs/wires. No change. I checked ALL the vacuum lines. No issues. I fired the parts cannon at it trying to figure it out. I will give you a brief rundown of the things I have tried or changed over the last few months.

Fuel Cap
Fuel Filter
Wires (NGK)
Plugs (Motorcraft)
MAF (car had a short ram cold air intake) reverted back to stock.
Cleaned Throttle Body
IAC
EGR
EGR Solenoid
DPFE
4 o2 Sensors. Bank 2 sensor 1 was hand tight. I took it out without a wrench. Figured I found the problem. Nope.

Pulled some live data and compared it to another CSVT. Idle for his was 789 mine sits at 720. MAF flow for his was identical at idle 2.8 g/s. My bank 2 long term fuel trim is +6.2 and my bank 1 is - 4.1. After driving for a couple days for about 2 hours total run time with multiple start cycles still encountering a hunting idle and stalling at low speeds. This is after the o2 sensor change and computer re-set.

Things I have noticed, weird whistling noise based on throttle position. 1/3 open. Only happens when driving can't replicate in the driveway. IMRC opens at 4200RPM with gradual opening of throttle body. Linkages are connected and operate freely.

Last few things I think it could be:

Bad o rings on the injector(s) causing a lean condition
Intake manifold needs cleaning, going to order gaskets and pull upper and lower next spring
Problem with the computer..? Re-flash?

Was wondering if anyone has had a similar problem, found a solution or has ideas I haven't thought of... ? Thanks for your time everyone.
 

ruwfo

CEG'er
Joined
Nov 23, 2021
Messages
65
Location
07419
Spray some carb cleaner (straw type can), on intake/around, if idle changes you've found you, the leaking part/area
 
Top