Contour Enthusiasts Group CEG

Modifications >> Transaxle

gsx_dan
Newbie

Reged: 09/05/06
Posts: 2
Input shaft seal leak
#1312544 - 09/05/06 08:42 AM

I just replaced the clutch and the slave cylinder/release bearing assembly with the unit that came with the spec clutch kit and it's leaking badly after the fluid gets to operating temp. There was no leak at first on initial startup and idle but then when I parked the car after a 10 minute drive I found a pretty big puddle and it seems to be coming from inside the bellhousing and making it's way down the little slot right at the bottom where it meets the oil pan plate.

Now that I look at the old slave cylinder I see that there is a seal in the back of it so I'm wondering if this is bad on the new unit? I also noticed a bit of RTV on the old unit around the surface that bolts up to the tranny, around the seal. Was this required or should the new unit have a gasket there that might be faulty? This is the first time I've done a Contour clutch so please excuse my ignorance.

Post Extras Print Post Remind Me! Notify Moderator

Entire thread
Subject Posted by Posted on
* Input shaft seal leak gsx_dan 09/05/06 08:42 AM
. * Re: Input shaft seal leak todras 09/05/06 02:00 PM
. * Re: Input shaft seal leak gsx_dan 09/05/06 04:01 PM
. * Re: Input shaft seal leak todras 09/05/06 06:15 PM

Extra information
0 registered and 20 anonymous users are browsing this forum.

Moderator:  RoadRunner, unisys12 



Permissions
You cannot start new topics
You cannot reply to topics
HTML is enabled
UBBCode is enabled

Thread views: 2594

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.025 seconds in which 0.016 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company