Contour Enthusiasts Group CEG

General >> Troubleshooting

Pages: 1 | 2 | >> (show all)
F111D F
Veteran CEG'er

Reged: 05/27/00
Posts: 635
Loc: Lucas,Ohio
Re: blower switch, runs high then quits new
#1310797 (Re: 96SEBlack) 09/01/06 04:36 PM

Yes this is not common, as others have said

How's your electrical abilities ie using an ohm meter?
With out removing (because the radio has to pulled the console removed the access the two screw on the bottom of the center trim panel before it can be removed)
To test blower switch on high unplug the connector at the blower motor check continuity/resistance from the BK/Rd (on the removed connector and the other test lead to good ground metal frame under the dash. Also unplug the connector at the resistor pack.
Reading should be the same as shorting the two test leads together. Meter on x-1 or lowest scale.
Do you smell a hot burnt smell when you run the blower for 20 secs emanating from the switch area?
The blower motor and the resistor pack uses the ground same connection. I notice the blower relay also uses that same ground point? That ground is located bottom of the RH door pillar. I doubt that problem many other circuits use that same ground. When is comes to heavy current draw the condition of the contacts on the switch and the relay K-14 shows up. Swap relay with a like one in the CJB under the dash. The relay above is the rear window defrost and one below is the wipers.

I"m using the 98 wiring schematic and don't have a 96 although the before 3/98 should be the same.

I just hate to remove interior trim pieces some clip usually breaks and HELLO rattles and squeaks.

Paul
I'll check back later once I take care a few honey-dos!

--------------------
Paul
98 Mystique LS 2ea (07/97)(08/98)

Post Extras: Print Post Remind Me! Notify Moderator
96SEBlack
Newbie

Reged: 10/21/03
Posts: 8
Re: blower switch, runs high then quits new
#1311086 (Re: F111D F) 09/02/06 03:27 AM

Thanks for all your suggestions!! I've been hesistant to remove too many parts during the week since this is my daily driver for work. I will tear into it this weekend and see what I can find.

Using a multimeter is not a problem and there isn't any burning smell when the switch cuts out after 20sec to 1min.

I'll post back and let you know what I find.




Post Extras: Print Post Remind Me! Notify Moderator
96SEBlack
Newbie

Reged: 10/21/03
Posts: 8
Re: blower switch, runs high then quits new
#1311376 (Re: 96SEBlack) 09/02/06 10:07 PM

I swapped the two yellow relays R13 (rear defroster) and R14 (blower motor). That didn't help.

I got to the switch, finally and found black/charred/melted plastic at the connector. The switch itself doesn't look as bad, but it has melted plastic also.

Is the switch and connector separate part numbers or does the switch come with a connector?

It looks like the 4 wires from the switch go to the resistor. Is there a Ford part number for these wires with connectors already attached at both ends? I doubt it, but I thought I would ask anyway.

Is the switch/connector just a weak component that went bad or is there something else that may have caused the switch to burn out like that?

Thanks for your help!!






Post Extras: Print Post Remind Me! Notify Moderator
Con-Man
CEG'er

Reged: 03/12/05
Posts: 89
Loc: ClarksVegas
Re: blower switch, runs high then quits new
#1311417 (Re: 96SEBlack) 09/02/06 11:38 PM

I had the same problem my blower was running on high for a long time then one day it just quit working. My connector was melted, I called the dealership and they wanted to charge me $29.00 for the connector. I decided to hit the savage yard I was very lucky I found a connector that was not damage. I took it off the car went to pay for it the lady that owned the salvage yard told me just take it no charge so I guess free beats $29.00.Installed the new connector blower operates on all three speeds. I'm glad the heat problem is fixed I must get the Tour ready for the winter and the snow. The Tour is our go to car in the snow the front wheel drive is awesome in the snow

--------------------
2006 Mustang GT
2004 Mustang GT (Gone)
2004 Yamaha FZ1
1995 Contour GL
1982 Cutlass 2 door

Post Extras: Print Post Remind Me! Notify Moderator
FavoriteMystaque
Hard-core CEG'er

Reged: 10/17/04
Posts: 1456
Re: blower switch, runs high then quits new
#1311445 (Re: Con-Man) 09/03/06 12:31 AM

I think the new connector (solder/shrinktube splice) does come with the switch, you could try just the switch to see if it works OK. I replaced the switch in my sister's Mystique, and did not do any wiring.

Post Extras: Print Post Remind Me! Notify Moderator
projectSHO89
Hard-core CEG'er

Reged: 09/19/02
Posts: 1788
Loc: St. Louis, MO
Re: blower switch, runs high then quits new
#1311683 (Re: 96SEBlack) 09/03/06 02:44 PM

BTW, if you're still within the 150K and 10 years (from in-service date), this is a covered repair under Owner Notification Program 01M07. Being a 96, you may have already passed the cutoff.

If you have to do it yourself, obtain Blower Switch Connector Repair Kit #F5RZ-14A411-AA (Less than $25) and perform the repair yourself.

Performing a SEARCH for "01M07" will yield quite a few relevent posts going back several years.

Steve

--------------------
98 Contour SE Sport 2.5 Duratec ATX The wifey's car
89 Taurus SHO - 246K miles
94 SHO ATX - 190K
1997 F-150 5.4L ATX - The Workhorse 150K.


ANY THREAD WITH "OMG" or "WTF" ETC IN THE TITLE WILL BE IGNORED!

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1 | 2 | >> (show all)


Extra information
0 registered and 21 anonymous users are browsing this forum.

Moderator:  horseydug, Ray 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 2030

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.074 seconds in which 0.069 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company