Contour Enthusiasts Group CEG

General >> Troubleshooting

Pages: 1
johnoh
CEG'er

Reged: 04/30/06
Posts: 63
code 332 on zetek 2.0
#1305994 - 08/24/06 10:36 PM

I have cel 332. After searching, it looks like cleaning the throttle body and egr ports is the suggested action, although I cannot find any links or pics on how to do this on the zetek. So far I have used a toothbrush and carb cleaner to clean as much if the tb as I could, so I am assuming I need to remove it to do it more thoroughly.

Does anyone have links/pics as to how to do this on the Zetek?

Does anyone have any other ideas? When I got the car a couple months ago I changed plugs, wires, cleaned MAF, replaced IAC and EGR, air and fuel filters. Thanks for any input.

--------------------
'95 Contour GL 2.0l automatic, 110k miles

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: code 332 on zetec 2.0 new
#1305996 (Re: johnoh) 08/24/06 10:42 PM

Same way. Remove, clean, reinstall.

Autozone link for EGR

Autozone link for TB

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
johnoh
CEG'er

Reged: 04/30/06
Posts: 63
Re: code 332 on zetec 2.0 new
#1306002 (Re: Tony2005) 08/24/06 10:52 PM

Thanks Tony. Looking at pics 14 and 15 on the TB link, it appears that the TB is not near as "deep" as I thought. Now I am wondering if removing it allows for better cleaning that what I did earlier with a toothbrush while it was still attached. Or am I supposed to clean well down below the level of the TB gasket, that is, below the TB too?

--------------------
'95 Contour GL 2.0l automatic, 110k miles

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: code 332 on zetec 2.0 new
#1306005 (Re: johnoh) 08/24/06 10:58 PM

What you have done is good enough as far as TB cleaning is concerned. Any further would be the intake manifold. That would be another maintenance item.

And for sure you don't want to mess with removing it if you don't have a new gasket handy (both IM and TB).

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
johnoh
CEG'er

Reged: 04/30/06
Posts: 63
Re: code 332 on zetec 2.0 new
#1306051 (Re: Tony2005) 08/25/06 12:11 AM

The pics to Cleaning EGR passages no longer exist, though if they were for the 6cyl I don't know if they would have helped anyway. Behind my i4 throttle body I see two vac lines that go into the housing under the TB and I have cleaned those, but I doubt they are EGR passages. Is there a link to cleaning EGR passages on the i4? I am having trouble figuring out why I am getting P0332.

--------------------
'95 Contour GL 2.0l automatic, 110k miles

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: code 332 on zetec 2.0 new
#1306099 (Re: johnoh) 08/25/06 01:34 AM

Originally posted by johnoh:
... Behind my i4 throttle body I see two vac lines that go into the housing under the TB and I have cleaned those, but I doubt they are EGR passages. .... I am having trouble figuring out why I am getting P0332.



Yes, those are EGR passages, for the DFPE sensor. Did the P0332 come on again after the cleaning?

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
johnoh
CEG'er

Reged: 04/30/06
Posts: 63
Re: code 332 on zetec 2.0 new
#1306319 (Re: Tony2005) 08/25/06 12:48 PM

Yes I did get 332 again after cleaning the passages and resetting pcm. What about that super thin line which is hard, only somewhat bendable, and is a light faded green, almost white in color? Its attached to a T-connector which attaches to those passages behind the TB. That thing looks like it could get clogged easily, although mine seems to go downward toward who-knows-what after a few inches so I have no idea if it is related to EGR flow. I tried to spray a little carb cleaner into it but to clean it I'd need a very thin reamer of some sort. I won't mess with it unless someone suggests it. Maybe I could get to the other end of it by jacking up the car and going underneath.

--------------------
'95 Contour GL 2.0l automatic, 110k miles

Post Extras: Print Post Remind Me! Notify Moderator
johnoh
CEG'er

Reged: 04/30/06
Posts: 63
Re: code 332 on zetec 2.0 (SOLVED) new
#1306905 (Re: johnoh) 08/26/06 12:32 PM

Having tried everything else I put on a new EGR Vac Solenoid. Getting the electrical connector off of the old one was very hard - it was stuck on. The new EGR solenoid produced the code as well, but instead of taking 3 minutes for the code to appear (that's how its happened up until now) it appeared in about 3 seconds. So I stuck the old one back on, and the CEL has been off now for a whole day. The problem must be the connector or the wires that come off of it. I'll let it be for now but if the code comes back my hunch is that a good cleaning of the connector and examination of the wires coming off of it will fix it permanently.

I wonder how many of our problems would not be there if every one of our cars had the wiring harness recall done (mine never did, and I am always finding new insulation cracks and exposed wires). Just a little exta resistance and the occasional short resulting from these stupid lame harnesses has to be a contributor to persistent CELs which result from a sensor being out of range.

--------------------
'95 Contour GL 2.0l automatic, 110k miles

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1


Extra information
0 registered and 2 anonymous users are browsing this forum.

Moderator:  horseydug, Ray 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 825

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.076 seconds in which 0.07 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company