Contour Enthusiasts Group CEG

General >> Troubleshooting

Pages: 1
m4gician
Veteran CEG'er

Reged: 06/05/06
Posts: 504
Loc: Toronto (Woodbridge)
radiator light (fan) ALWAYS come on during start..
#1305621 - 08/24/06 05:15 AM

This stupid light came on and off in the past but only briefly on selected COLD days. Now in the summer this light ocmes on everytime I start the car and won't turn off until I get the car moving for about a few minutes. Is an indication I have to change the coolant? Or change the radiator fan at all? What must be done here?

--------------------
1998 Mercury Mystique LS

- Looking for SVT EXHAUST, SVT Rear bumper (silver frost) and ANY rocker mouldings (side skirts)

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: radiator light (fan) ALWAYS come on during start.. new
#1305622 (Re: m4gician) 08/24/06 05:17 AM

Add 50/50 coolant to 15 mm above the max line and you should be fine. In addition, if you park on a slope, park facing downhill rather than uphill.

Main Site FAQ

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
projectSHO89
Hard-core CEG'er

Reged: 09/19/02
Posts: 1788
Loc: St. Louis, MO
Re: radiator light (fan) ALWAYS come on during start.. new
#1305643 (Re: m4gician) 08/24/06 11:02 AM

The light is simply an indication that the sensor in the tank isn't seeing the coolant at the proper level.

If the tips that tony provided don't turn off the light, the sesnor may be contaminated or may have failed.

Steve

--------------------
98 Contour SE Sport 2.5 Duratec ATX The wifey's car
89 Taurus SHO - 246K miles
94 SHO ATX - 190K
1997 F-150 5.4L ATX - The Workhorse 150K.


ANY THREAD WITH "OMG" or "WTF" ETC IN THE TITLE WILL BE IGNORED!

Post Extras: Print Post Remind Me! Notify Moderator
RawBurt
Hard-core CEG'er

Reged: 08/17/04
Posts: 6791
Loc: SE-MI CEG
Re: radiator light (fan) ALWAYS come on during start.. new
#1305666 (Re: m4gician) 08/24/06 12:45 PM

I've seen cases where the lights indicates... Low coolant, weak coolant, loss in pressure.

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1


Extra information
0 registered and 34 anonymous users are browsing this forum.

Moderator:  horseydug, Ray 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 420

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.074 seconds in which 0.069 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company