Contour Enthusiasts Group CEG

General >> Troubleshooting

Pages: 1 | 2 | 3 | (show all)
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Battery Light
#1304382 - 08/22/06 02:42 AM

Tonight after coming out of a restaurant I turned on the car and the red battery light was on and it was solid red. I turned off the car and turned it back on and the light was still there. The battery and the alternator are less than 6 months old. The radio keeps turning on and off. Anyone have any ideas of whats goin on?

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
RawBurt
Hard-core CEG'er

Reged: 08/17/04
Posts: 6791
Loc: SE-MI CEG
Re: Battery Light new
#1304391 (Re: DyComet) 08/22/06 02:55 AM

Your alternator is taking a dump, put another one in before you are left standed. Soon your gauges will start acting up and it'll die on you, symptoms are about to get worse.

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Battery Light new
#1304432 (Re: RawBurt) 08/22/06 03:50 AM

Originally posted by RawBurt:
Your alternator is taking a dump,..



Maybe but I would check the megafuse first.

Thread with megafuse

Also test the battery and alternator.

Charge the battery well and then test battery and alternator. Your symptoms could be a weak or dying battery (probably due to a bad alternator).

Battery test. Engine off, headlights on for one minute. Voltage across battery terminals should be 12 to 12.5.

Alternator test. Engine running, voltage across battery terminals should be 14 to 14.5.



--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Edited by Tony2005 (08/22/06 03:52 AM)

Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1304779 (Re: Tony2005) 08/22/06 09:30 PM

Alright so I just took out the mega fuse, is there any way of testing to see if it is still in working condition and would these be at any local stores or would they have to be specially ordered from Bill.

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Battery Light new
#1304784 (Re: DyComet) 08/22/06 09:54 PM

Originally posted by DyComet:
Alright so I just took out the mega fuse, is there any way of testing to see if it is still in working condition and would these be at any local stores or would they have to be specially ordered from Bill.



"Ohm" it. It should be close to O ohms. If it has high to infinite ohms, then you know the fuse is broken.

And I think you can get from Autoparts stores.

Read this thread

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1304806 (Re: Tony2005) 08/22/06 10:42 PM

Well I found it at Autozone and since it was only $5 I replaced the part anyway and the battery light still didn't go away. I then had the alternator tested and it isn't powering the battery at all. So I guess now it is safe to assume that I get to replace the alternator again, the "remanufactured" one in the car had less than 5k on it. What a piece.

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
RawBurt
Hard-core CEG'er

Reged: 08/17/04
Posts: 6791
Loc: SE-MI CEG
Re: Battery Light new
#1304808 (Re: DyComet) 08/22/06 10:44 PM

I knew it... !!!!!

What brand was it?

Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1304812 (Re: RawBurt) 08/22/06 10:50 PM

I don't really remember, but basically the standard autozone POS brand, and unfortunately, I'm going have to use theirs again because I need the car to be running by tomorrow night. I'm really not looking forward to doing this tomorrow.

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1305479 (Re: DyComet) 08/24/06 01:21 AM

Alright alternator replaced and battery light went off....or so I thought. The alternator now whines at high rpm and above 6k the battery light starts to flicker, anyone have any other ideas?

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Battery Light new
#1305490 (Re: DyComet) 08/24/06 01:39 AM

Wiring. What year and how many miles? And did you test the battery?

Also check fog lamp Fuse 5 and the holder.
In this thread

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Edited by Tony2005 (08/24/06 01:41 AM)

Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1305491 (Re: Tony2005) 08/24/06 01:41 AM

1999 with 80,000. I didn't test the battery but it's about 5 months old. I'll test it tomorrow and check the fuse. Thanks for the help.

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
RawBurt
Hard-core CEG'er

Reged: 08/17/04
Posts: 6791
Loc: SE-MI CEG
Re: Battery Light new
#1305668 (Re: DyComet) 08/24/06 12:50 PM

Originally posted by DyComet:
Alright alternator replaced and battery light went off....or so I thought. The alternator now whines at high rpm and above 6k the battery light starts to flicker, anyone have any other ideas?




Ok, this is identical to my current problem. I could be just a bad alternator, but I dont know. I demand that you PM me the second you resolve this problem and inform me of what was done. If you do not inform me right away, I will find out where you live, knock on your door and then break your legs. j/k

Seriously though, I've been battling this problem for a couple months now. And I need some closure.

PS, I really do know where you live. I have your address and everything muhahahahaha

Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1308846 (Re: RawBurt) 08/29/06 10:16 PM

Alright, update time. All fuses checked out. I had the alternator tested and the battery they both were good. Since the light only flickers at high rpm's when accelerating hard I think the belt might be slipping. But here's the question, why? Bad install?

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
RayModerator
Addicted CEG'er

Reged: 07/10/01
Posts: 7100
Loc: San Antonio/Austin, TX
Re: Battery Light new
#1308897 (Re: DyComet) 08/29/06 11:41 PM

why, what? reasons for a belt to slip?

failing tensioner, worn belt (stretched), loose pulley/pulleys


--------------------
'99 CSVT - Silver #222/276
In a constant state of blow-off euphoria.
Originally posted by Kremitthefrog:
I like to wear dresses and use binoculars to watch grandmas across the street.




Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1308981 (Re: Ray) 08/30/06 01:34 AM

I'll get a new belt and see if that fixes the problem and check to make sure the belt is on there correctly.

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
Pick
CEG'er

Reged: 08/16/02
Posts: 80
Loc: Houston, TX
Re: Battery Light new
#1309443 (Re: DyComet) 08/30/06 07:42 PM

Hey guys, i'm having some similar problems right now also.

I just installed new Alternator and Battery, becuase my car was dying on me. After driving for one day, it is doing it again. System is not charging the battery and now the battery has no juice becuase it was running the whole system. I guess i got a bad alternator or possibly having some other type of electrical problem like megafuse or wiring.
Any ideas???

I'll stay tuned...

--------------------
"Not a newbie" Been here since it all started!!
98 silver SVT Contour
several mods and counting
www.pickettperformance.com
"Remember, you're part of the human race, try not to embarrass the rest of us"

Post Extras: Print Post Remind Me! Notify Moderator
RayModerator
Addicted CEG'er

Reged: 07/10/01
Posts: 7100
Loc: San Antonio/Austin, TX
Re: Battery Light new
#1309460 (Re: Pick) 08/30/06 08:21 PM

Again, a megafuse problem would cause a charging light to remain illuminated at ALL times.
(there are OTHER reasons to be on at all times, but you get my point...)

If the light is off at all, then the fuse is not the problem.


--------------------
'99 CSVT - Silver #222/276
In a constant state of blow-off euphoria.
Originally posted by Kremitthefrog:
I like to wear dresses and use binoculars to watch grandmas across the street.




Post Extras: Print Post Remind Me! Notify Moderator
RawBurt
Hard-core CEG'er

Reged: 08/17/04
Posts: 6791
Loc: SE-MI CEG
Re: Battery Light new
#1309466 (Re: Ray) 08/30/06 08:29 PM

You know what I find funny... Out of the 12,000 some odd members on this site, noone has expereinced and solved the "battery light at high RPM" problem.

Oh well, by the sounds of it more and more CEG'ers are running into this. Someone is bound to figure it out.

Post Extras: Print Post Remind Me! Notify Moderator
RayModerator
Addicted CEG'er

Reged: 07/10/01
Posts: 7100
Loc: San Antonio/Austin, TX
Re: Battery Light new
#1309479 (Re: RawBurt) 08/30/06 08:45 PM

Depends on which issue you are referring to.


the MOST COMMON high-rpm light is from floating brushes on the alternator, a sign of an aging alternator.

Solving involves either rebuilding the brushes (technically do-able, but not worth it to me...) or replacing the alternator.

There is another issue, which is fixed by GoldenTour's wire fix...

Is there a third issue that is actually a verified "third" issue?





--------------------
'99 CSVT - Silver #222/276
In a constant state of blow-off euphoria.
Originally posted by Kremitthefrog:
I like to wear dresses and use binoculars to watch grandmas across the street.




Post Extras: Print Post Remind Me! Notify Moderator
gooserex
CEG'er

Reged: 03/16/05
Posts: 140
Loc: Toronto
Re: Battery Light new
#1309597 (Re: Ray) 08/30/06 11:50 PM

Originally posted by Ray:
Depends on which issue you are referring to.


the MOST COMMON high-rpm light is from floating brushes on the alternator, a sign of an aging alternator.

Solving involves either rebuilding the brushes (technically do-able, but not worth it to me...) or replacing the alternator.

There is another issue, which is fixed by GoldenTour's wire fix...

Is there a third issue that is actually a verified "third" issue?




I was going to say there is the wire fix which in more cases that i've read on CEG fixed the flicking battery light at high RPM, which I myself have every now and then which leads me to believe that the wire fix is the solution. I've read on CEG ppl replace everything and the problem still haunts them and eventually the wire fix fixed the problem. It's a CHEAP fix that's for sure and couldn't hurt!

--------------------
--------------------
1999 Black/Tan CSVT
#2658 of 2760
201,000+km
- K&N, Magnecor race wires, Optima red top, BAT Euro Kit, KVR CF pads, PIAA Plasma Ion bulbs.

1989 Yamaha FZR600 - 40,000+km
- K&N Pods, Stage 3 Jets, V&H 4-1 exhaust

Post Extras: Print Post Remind Me! Notify Moderator
DyComet
CEG'er

Reged: 08/31/05
Posts: 90
Loc: Nasti Nati
Re: Battery Light new
#1309733 (Re: gooserex) 08/31/06 02:16 AM

Anyone have a link to the wire fix? That would be awesome.

--------------------
FS:
Stock Diff.
Stock Shift Forks
SE Front and Rear Bumper

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Battery Light new
#1309743 (Re: DyComet) 08/31/06 02:31 AM

In Duratec Maintenance FAQ

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
csc99svt
Hard-core CEG'er

Reged: 08/20/02
Posts: 1355
Loc: Smyrna, Tn
Re: Battery Light new
#1310636 (Re: DyComet) 09/01/06 11:20 AM

quick question:

my light has flickered for the past couple of days....never actually hitting full brightness....very random....no pattern.....

this morning, i had to come to work early and it is still dark outside....no flicking light, but dimming headlights while driving....no problems starting my car....???

any suggestions?

--------------------
--Chris--
1999 Silver Frost SVT
#1671 of #2760

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Battery Light new
#1311042 (Re: csc99svt) 09/02/06 01:24 AM

Originally posted by csc99svt:
..my light has flickered for the past couple of days....never actually hitting full brightness....very random....no pattern.....

this morning, i had to come to work early and it is still dark outside....no flicking light, but dimming headlights while driving....no problems starting my car....???

any suggestions?



Most probably alternator dying.

Charge the battery well, then test battery and alternator.

Battery test. Engine off, headlights on for one minute. Voltage across battery terminals should be 12 to 12.5.

Alternator test. Engine running, voltage across battery terminals should be 14 to 14.5.


--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
RawBurt
Hard-core CEG'er

Reged: 08/17/04
Posts: 6791
Loc: SE-MI CEG
Re: Battery Light new
#1312584 (Re: DyComet) 09/05/06 01:34 PM

Updates, updates! Give me updates.

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1 | 2 | 3 | (show all)


Extra information
0 registered and 27 anonymous users are browsing this forum.

Moderator:  horseydug, Ray 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 6500

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.076 seconds in which 0.068 seconds were spent on a total of 13 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company