Contour Enthusiasts Group CEG

General >> Troubleshooting

Pages: 1
gliderjoe
CEG'er

Reged: 03/25/04
Posts: 229
Loc: San Francisco
P1131 code after UIM/LIM rebuild. New O2 sensor?
#1303310 - 08/19/06 04:21 PM

I'm getting the P1131 code, fuel air metering (O2 sensor) CEL after a UIM/LIM rebuild. I cleared the code and it came back within 10 minutes. When I was replacing the rear valve cover gaskets, I disconnected the O2 sensor connector in order to maneuver the wire harness back more. When I reconnected it, I used some electric cleaner for the terminals. I am thinking that this could have caused the O2 sensor to malfunction. I checked everything else and all else is connected properly. Do I need a new O2 sensor?

--------------------
1998 Black CSVT, 75k mi

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: P1131 code after UIM/LIM rebuild. New O2 sensor? new
#1303327 (Re: gliderjoe) 08/19/06 05:55 PM

Per TSB, some reasons are
P1131 - Lack of HO2S-11 Switch, Indicates Lean When an HO2S sensor indicates lean at the end of a test, the system is trying to correct for an over-lean condition. The code is set when the fuel control system no longer detects switching for a calibrated amount of time.

Electrical:
Short to VPWR or VREF in harness or HO2S
HO2S circuit shorted to Ground
Water in harness connector
Open circuit
Corrosion or poor mating terminals and wiring
Damaged HO2S
Damaged PCM (other DTCs should be present)

Fuel System:
Excessive fuel pressure (stuck fuel pressure regulator, restricted fuel return lines, etc.)
Leaking/contaminated fuel injectors or fuel pressure regulator
Low fuel pressure or running out of fuel (fuel pump concern, fuel supply line restrictions, low fuel level, etc.)
Vapor recovery system (stuck VMV, etc.)

Induction System:
MAF contamination
Air leaks between MAF and throttle plate
PCV system / Other vacuum leaks
Improperly seated engine oil dipstick

EGR System:
Leaking gasket
Stuck EGR valve / Leaking diaphragm or EVR

Base Engine:
Oil overfill
Incorrect cylinder compression
Exhaust leaks before or near the HO2S
Secondary air stuck on

I suggest you check/wipe out the connectors first and then check for vacuum leaks at the gaskets. Did you put new gaskets for everything you took out? And did you torque everything back to specs?

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
gliderjoe
CEG'er

Reged: 03/25/04
Posts: 229
Loc: San Francisco
Re: P1131 code after UIM/LIM rebuild. New O2 sensor? new
#1305493 (Re: Tony2005) 08/24/06 01:44 AM

Awesome info Tony, thanks. I found that my O2 sensor connector wasn't seated all the way in and my accordian tube was loose. Alls good now.

--------------------
1998 Black CSVT, 75k mi

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1


Extra information
0 registered and 36 anonymous users are browsing this forum.

Moderator:  horseydug, Ray 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 701

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.078 seconds in which 0.073 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company