Contour Enthusiasts Group CEG

General >> Troubleshooting

Pages: 1 | 2 | >> (show all)
SVT3391
CEG'er

Reged: 07/28/04
Posts: 186
Loc: Columbia, MD
Accelerate from 40 MPH to 130 MPH in 0.5 sec
#1290752 - 08/01/06 02:31 AM

Well, if the speed was accurate, I would be very happy.

It was the speedometer behaving funny. I have 98 CSVT. The speedometer and odometer have been very accurate for the past 8 years (tested against my Garmin 2720 GPS). This afternoon while driving in D.C.'s rush hour, I drove over a man-hole bump and then immediately observed the speedometer needle shaking back and forth. When I had a full stop, the speedo stayed at 0 MPH. Then when I slowly started, it moved very fast to like 40 MPH and then jumped between 40 and 80 MPH. When I finally drove on 495 at regular speed (about 60 MPH), the speedo jumped between 80MPH and 120 MPH. The techometer was always steady. The AC was on, the radio was on, no strange wiper action.

I did a search and found most likely it was due to a VSS failure. Some also mentioned it could be battery problem. The battery was recently replaced 1000 miles ago. I haven't tested the battery and alternator. I should pick up a multimeter for that. But from the description, it seems to be either a VSS or the speedo itself. Since VSS is cheaper, I will try to start from this.

I found in Tony2005's post (from unisys12 I think), the VSS part is F-F5RZ-9E371-BC. However, in the write up the transmission was CD4E, not MTX75. Will the part be the same or different? Also, currently I have the E0s with 205/55/16 (original size for 98) but I have a set of E1s with brand new 215/50/16 BFG Traction V in my garage. I know that will throw off my speedo reading by about 6%. In order to fix that, can I find different VSS for different model year, or do I need to use a speedometer for 99-00?

I remember not long ago there was a discussion on the instrument cluster. It seems 98 CSVT and 99/00 CSVT's clusters are not interchangeable. Is it true? Can I just use the speedometer from a 99/00? I found it is almost impossible to find a 98 CSVT speedometer with miles less than 80K.

I really appreciate any help. Thanks!

--------------------
98 Silver Frost E0 SVT. 1011/6535. DOB 05/16/97
Owned since new. Optimized y-pipe. Bosal Exhaust w/ silencer inserts.
K&N intake w/ MAF. Ford Racing 9mm wires.
05 Saab 9-2X Aero Satin Grey. Cobbs Accessport Stage 2.

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1290759 (Re: SVT3391) 08/01/06 02:43 AM

Originally posted by SVT3391:
..... But from the description, it seems to be either a VSS or the speedo itself. Since VSS is cheaper, I will try to start from this. ...




Cheaper to check connector on top of transmission and connector behind dash panel first.

If those are fine, then most probably VSS.
www.teamfordparts.com
VEHICLE SPEED SENSOR, Contour, Mystique, 2.5L, Manual Trans., From 2/1/95 95-00 CEG $28.85
Order By Description. Parts & Prices For Estimating Only.

VSS how to from Autozone.
http://www.autozone.com/servlet/UiBroker?ForwardPage=/az/cds/en_us/0900823d/80/1b/cb/ad/0900823d801bcbad.jsp

Instrument Panel R and R
http://www.contour.org/ubbthreads/showflat.php?Cat=&Board=trouble&Number=1012899&fpart=1&PHPSESSID=

Correct part number for ATX VSS is F5RZ9E731AC (the VSS part number was posted wrongly in how to). Not sure what the Manual ATX part number is. Tony (CSVT1214) would know as he changed his last year (if he can find the invoice). If not, I'm sure you will have it when you buy the part.

Speed difference is 1.7 % with the change in tires (205-55-16 going to 215-50-16). When speedometer is showing 60 MPH, car is actually 59 MPH. Don't mess with the panel just for that. Too much risk just for that.
http://www.miata.net/garage/tirecalcold.html


--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Edited by Tony2005 (08/01/06 03:00 AM)

Post Extras: Print Post Remind Me! Notify Moderator
SVT3391
CEG'er

Reged: 07/28/04
Posts: 186
Loc: Columbia, MD
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1291014 (Re: Tony2005) 08/01/06 01:21 PM

Thanks for the reply.

How do I check connector behind dash panel? Do I need to disassemble the dash panel and take out the cluster?

Thx!

--------------------
98 Silver Frost E0 SVT. 1011/6535. DOB 05/16/97
Owned since new. Optimized y-pipe. Bosal Exhaust w/ silencer inserts.
K&N intake w/ MAF. Ford Racing 9mm wires.
05 Saab 9-2X Aero Satin Grey. Cobbs Accessport Stage 2.

Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1291015 (Re: SVT3391) 08/01/06 01:22 PM

One post above your 9:21 AM post. Click on link to Instrument Panel R and R.

And no, you do not need to remove the cluster. Just check connector to see if it is loose.

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Edited by Tony2005 (08/01/06 01:24 PM)

Post Extras: Print Post Remind Me! Notify Moderator
CSVT1214
Hard-core CEG'er

Reged: 11/02/03
Posts: 4051
Loc: Plainville, CT
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1291020 (Re: Tony2005) 08/01/06 01:31 PM

Yup, mine turned out to be just a bad connection. I bought a new VSS anyways because at the time I didn't know.

When I did my engine swap, the VSS missed getting unplugged so when the engine was dropped down, it pulled until the wires broke free. I put them back in and it worked perfectly, but over the winter, they came loose again. I could of just pushed and locked the wires in tighter instead of replacing the sensor.

Also, a bad VSS or bad VSS wire connection would throw a CEL. Mine actually showed 2 codes for the VSS wires.

If there is no codes, then I would suspect a speedo problem.

--------------------
Tony

1998 SVT Contour (B/MB) #542 3L
1998 SVT Contour (SF/MB) #1266 parts car
2000 SVT Contour (SF/MB) #1533 3L swap to begin!

Post Extras: Print Post Remind Me! Notify Moderator
SVT3391
CEG'er

Reged: 07/28/04
Posts: 186
Loc: Columbia, MD
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1291028 (Re: CSVT1214) 08/01/06 01:50 PM

I haven't got a code yet. It was probably 40 miles since the the speedo behaved funny. How long it will throw a code for VSS related issue?

I know I should check before ask further question. But, for the worst part, if the speedo is really broken, can I get any year CSVT speedo to work?

--------------------
98 Silver Frost E0 SVT. 1011/6535. DOB 05/16/97
Owned since new. Optimized y-pipe. Bosal Exhaust w/ silencer inserts.
K&N intake w/ MAF. Ford Racing 9mm wires.
05 Saab 9-2X Aero Satin Grey. Cobbs Accessport Stage 2.

Post Extras: Print Post Remind Me! Notify Moderator
BrApple
Hard-core CEG'er

Reged: 12/23/01
Posts: 6910
Loc: Enfield, CT
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1291040 (Re: SVT3391) 08/01/06 02:10 PM

since you have a E0 you will need one from a E0

--------------------
- 95 Mystique LS - Zetec/5spd
- 99 Contour SeVT Sport - Duratec/5spd

Official NE-CEG Contour/Mustang Family


Post Extras: Print Post Remind Me! Notify Moderator
Tony2005
Addicted CEG'er

Reged: 06/19/05
Posts: 5345
Loc: Virginia, USA
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1291048 (Re: SVT3391) 08/01/06 02:20 PM

Originally posted by SVT3391:
I haven't got a code yet. It was probably 40 miles since the the speedo behaved funny. How long it will throw a code for VSS related issue?
...



No telling when. My speedometer went weird for a minute or so during a wet day in February (or March) with no codes, and then went kaput in December of the same year (with CEL and flashing ATX "OD off" light).

I think Tony(CSVT1214) posted once that the broken VSS did not affect his car's drivability other than a dead speedometer as it is/was a MTX. ATX's must get the broken VSS changed immediately or risk major tranny trouble.

--------------------
"Always do the cheap and easy ones first."

1996 V6 ATX 96K miles


Post Extras: Print Post Remind Me! Notify Moderator
SVT3391
CEG'er

Reged: 07/28/04
Posts: 186
Loc: Columbia, MD
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1300082 (Re: Tony2005) 08/14/06 12:58 PM

Oddly enough that after I disconnected the negative from the battery for 5 minutes and reconnected it, a bunch of strange behaviors disappeared. The speedo has not jumped once for the last 250 miles I travelled. Before I reset the battery, the speedo needle was dancing like the VU meter on a highend audio amplifier. Now it is just steady.

I am still buying a VSS from TeamFord just for the peace of mind. It seems to me that the ECU has something to do with the speedo (or just a coincidence?) so resetting it fixed the problem.

Originally posted by Tony2005:
Originally posted by SVT3391:
... I am not sure and will have to give it some time to see if this is indeed the case. So I will hold off my purchase of a new VSS just for now.
...



If the plastic (old ones has plastic) breaks and ends up in the tranny, you are looking at $3,000 or so. For a $40 VSS, this is not a risk worth taking.




--------------------
98 Silver Frost E0 SVT. 1011/6535. DOB 05/16/97
Owned since new. Optimized y-pipe. Bosal Exhaust w/ silencer inserts.
K&N intake w/ MAF. Ford Racing 9mm wires.
05 Saab 9-2X Aero Satin Grey. Cobbs Accessport Stage 2.

Post Extras: Print Post Remind Me! Notify Moderator
CSVT1214
Hard-core CEG'er

Reged: 11/02/03
Posts: 4051
Loc: Plainville, CT
Re: Accelerate from 40 MPH to 130 MPH in 0.5 sec new
#1300088 (Re: SVT3391) 08/14/06 01:09 PM

This is starting to look like it might of just been a bad battery connection. The car will do all sorts of wierd things if one of the terminals is loose.

--------------------
Tony

1998 SVT Contour (B/MB) #542 3L
1998 SVT Contour (SF/MB) #1266 parts car
2000 SVT Contour (SF/MB) #1533 3L swap to begin!

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1 | 2 | >> (show all)


Extra information
0 registered and 58 anonymous users are browsing this forum.

Moderator:  horseydug, Ray 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 2358

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.096 seconds in which 0.09 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company