Contour Enthusiasts Group CEG

Modifications >> Suspension

Pages: 1
coatsy
Veteran CEG'er

Reged: 10/13/03
Posts: 669
Loc: Ontario Canada
Need some advice
#1282199 - 07/20/06 01:37 AM

So I know that I need a rt front bearing, GOt the nororius humming vibration sound that gets WAY worse on left hand tunrs or corners. For the past 6 months whenever i am stopped and proceed to accelerate I could hear this click noise in the front right side, it has gotten progressively worse to the point that now when I turn right I hear a BIG clunk and then when I straighten out I hear a smaller clunk on the right side (its a painful sounding noise). Any thoughts??

--------------------
1999 Mystique Sport 2nd owner bought it in Sept 03
120000km 4 door, leather, loaded pics on cardomain, coatsy

Post Extras: Print Post Remind Me! Notify Moderator
TourDeForce
Hard-core CEG'er

Reged: 03/04/03
Posts: 7117
Loc: West Palm Beach, FL - Going to Jupiter someday
Re: Need some advice new
#1282229 (Re: coatsy) 07/20/06 02:19 AM

Sounds like maybe your struts are moving around a bit. Do you have a camber kit? 'Cause that is where I see this happening most often, with the camber kit.

--------------------
Must be that jumbly-wumbly thing happening again.

Post Extras: Print Post Remind Me! Notify Moderator
coatsy
Veteran CEG'er

Reged: 10/13/03
Posts: 669
Loc: Ontario Canada
Re: Need some advice new
#1282255 (Re: coatsy) 07/20/06 03:07 AM

Nope no camber kit.. It almost feels like something is shifting out and then when I straighten up it clicks back in,. Frustrating as it won't do it unless I am driving, i.e. if I am stopped and turn the wheels it won't do it..
I am guessing it has something to do with the steering..
Could it be a control arm issue? Or ball joint? Or tie rod?



--------------------
1999 Mystique Sport 2nd owner bought it in Sept 03
120000km 4 door, leather, loaded pics on cardomain, coatsy

Post Extras: Print Post Remind Me! Notify Moderator
coatsy
Veteran CEG'er

Reged: 10/13/03
Posts: 669
Loc: Ontario Canada
Re: Need some advice new
#1284266 (Re: coatsy) 07/23/06 06:49 PM

Its like a Knocking sound when I turn a corner, and then it kocks again when I straighten up..
Anyone else?

--------------------
1999 Mystique Sport 2nd owner bought it in Sept 03
120000km 4 door, leather, loaded pics on cardomain, coatsy

Post Extras: Print Post Remind Me! Notify Moderator
TourDeForce
Hard-core CEG'er

Reged: 03/04/03
Posts: 7117
Loc: West Palm Beach, FL - Going to Jupiter someday
Re: Need some advice new
#1284369 (Re: coatsy) 07/23/06 10:12 PM

check that top nut on your strut/strut towers up front. Sounds just like the struts are bangin' around...

--------------------
Must be that jumbly-wumbly thing happening again.

Post Extras: Print Post Remind Me! Notify Moderator
KingpinSVT
Addicted CEG'er

Reged: 05/21/03
Posts: 5600
Loc: Ocala, FL
Re: Need some advice new
#1284539 (Re: TourDeForce) 07/24/06 03:36 AM

If the struts were loose, it wouldnt just make one clunk when turned. They rattle (many clunks) over evey little bump. You can feel it in the floorboards. If its just one clunk, I doubt the struts are loose. However, they are easy enough to check, so you might as well.

--------------------
#4559 of 6535 born on Feb 17, 1998
Black 1998.5 CSVT

FOR SALE [cleaning house]: SVT rear swaybar. Reasonable offer and its yours!

Post Extras: Print Post Remind Me! Notify Moderator
coatsy
Veteran CEG'er

Reged: 10/13/03
Posts: 669
Loc: Ontario Canada
Re: Need some advice new
#1284786 (Re: coatsy) 07/24/06 03:54 PM

No clunks or noises on bumps just on turning.

--------------------
1999 Mystique Sport 2nd owner bought it in Sept 03
120000km 4 door, leather, loaded pics on cardomain, coatsy

Post Extras: Print Post Remind Me! Notify Moderator
MtnMan SVT
New CEG'er

Reged: 08/14/05
Posts: 15
Loc: Ann Arbor, MI
Re: Need some advice new
#1285579 (Re: coatsy) 07/25/06 03:14 PM

When I broke the sway bar end-links on my taurus I had similar results, but that was on the rear of the car. I'm still not sure what was actually making the clunking sound, but when I replaced the end links it stopped.

I would pull the wheel off and inspect everything as well as you can. Try to get a look at as many bushings as you can to see if they're worn out. A good way to check bushings on control arms and end links is to just push and pull on them hard with your hands to see if you get any knocking or excessive movement.

--------------------
'98 SVT Contour
(Bilstein Struts w/BAT Euro Spring kit.)
'95 SHO Taurus (R.I.P.)

Post Extras: Print Post Remind Me! Notify Moderator
richs
CEG'er

Reged: 04/02/02
Posts: 183
Loc: NW New Jersey
Re: Need some advice new
#1285781 (Re: MtnMan SVT) 07/25/06 06:12 PM

Check for a broken spring. My 4 cylinder did that.

Rich S

--------------------
1998 SVT
1995 Contour 2.5 MTX 215K miles Son's car(dead and buried)
1997 Contour 2.0 ATX
1998 Contour 2.5 ATX
2004 Tauras Wagon 3.0 Duratec


Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1


Extra information
0 registered and 20 anonymous users are browsing this forum.

Moderator:  Andy W., Auto-X Fil 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 593

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.02 seconds in which 0.015 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company