Contour Enthusiasts Group CEG

Branches >> Eastern Canada

Pages: 1 | 2 | 3 | (show all)
ZER0
CEG'er

Reged: 05/24/03
Posts: 135
Loc: Toronto, Ontario
Re: Anyone interested in a repair resource for mem new
#1059061 (Re: MazTour) 09/26/05 04:22 AM

I've got an awesome mechanic in the Mississauga area, Swaped the alt. out of my 99 V6 for 260. Really nice guy. Message me if you want the contact info.

Post Extras: Print Post Remind Me! Notify Moderator
m4gician
Veteran CEG'er

Reged: 06/05/06
Posts: 504
Loc: Toronto (Woodbridge)
Re: Anyone interested in a repair resource for mem new
#1286898 (Re: SVTCANUK) 07/26/06 11:25 PM

Minute Muffler on St. Clair and Runnymede (GTA), very friendly guys, and will take cash and give good price.

--------------------
1998 Mercury Mystique LS

- Looking for SVT EXHAUST, SVT Rear bumper (silver frost) and ANY rocker mouldings (side skirts)

Post Extras: Print Post Remind Me! Notify Moderator
European
CEG'er

Reged: 06/04/06
Posts: 82
Loc: Eastern Toronto, Canada
Re: Anyone interested in a repair resource for mem new
#1287345 (Re: m4gician) 07/27/06 03:27 PM

The guys at Thruway Muffler at 300 Dundas St E. Whitby and the guys at Mr.D's Auto Service at 1211 Kingston Rd. Pickering are some goood duudes with some gooood prices.

--------------------
-JD. 1996/V6/LX. Killer Bass, & A Few Other Mods.



Post Extras: Print Post Remind Me! Notify Moderator
rz_ca
Newbie

Reged: 07/27/06
Posts: 2
Loc: Waterloo, Ontario
Re: Anyone interested in a repair resource for mem new
#1287723 (Re: European) 07/27/06 11:26 PM

Hi, guys, really great to find out this forum. Maybe someone can give me some advice on my 98 contour SE. OK, there is the story. I'm in Kitchener. I bought this contour SE two month ago, the odometer reading was 200k. I didn't drive on the highway until this Monday on a trip to Niagara Falls. After I got there, the auto transmission start to function very funny. It won't engage after the red light stop, I have to step on the accelerator hard, then suddenly it engaged and car thrust out. From gear 1 to gear 2, the change is harsh and the engine speed is not stable (up and down until the speed was brought up). After 60km/h, every thing works smooth. The problem has been the same since last trip.

The thing is there has been a transmission rebuilt on the first owner at about 100k. This car hasn't give me any rouble when I only drove on local. It seems the problem is from gear 1 to gear 2 when speed is under 40km/h.

Does it mean this auto transmssion is nearly dead? How can I deal with it? I don't want put another 2000 dollar into this car. Maybe a used transmission? or maybe it is only problem with the torque convertor? Oh, there is another thing, when the car idle at red light, the engine periodicly shaking, it seems the engine engaged for a while then lost, and then engaged. The shaking is from this change.

Thanks a lot guys.

--------------------
98 Ford Contour SE, Silver grey

Post Extras: Print Post Remind Me! Notify Moderator
Pages: 1 | 2 | 3 | (show all)


Extra information
0 registered and 15 anonymous users are browsing this forum.

Moderator:  Gerald, mbb41 

Print Thread

Permissions
You cannot start new topics
You cannot reply to topics
HTML is disabled
UBBCode is enabled

Thread views: 7096

Jump to

Contact Us Contour.org

*
UBB.threads™ 6.2.3

Generated in 0.024 seconds in which 0.017 seconds were spent on a total of 14 queries. Zlib compression enabled.

Copyright 1999-2005 Lance Kinley

CEG and contour.org are not affiliated with nor endorsed by Ford Motor Company