+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 10 of 11

Thread: Window switches don't light up/ unlock button doesnt work???

  1. #1
    Join Date
    Jun 2005
    Location
    Pittsburgh
    Posts
    1,958

    Default Window switches don't light up/ unlock button doesnt work???

    Ok so I was messing w/ some new LED switches and now that I have it all put back together. All the window switches (excluding the driver main switch board) do not light up? How could this happen? I've tested the switches to make sure they light up i.e. tried pulling the passenger LED window switch and plugged it into the passanger door lock switch and it lights up. Just the window switch/socket of the passenger and both rears now do not light up.

    Info to help solve the prob:
    1)Both rear switches do work when you try to roll down the windows (but don't light up)
    2)Passenger window will not wind up or down from the passenger switch, however, it will wind up/down from the driver main switch)
    3) passenger door lock button works but the unlock does not.
    4) All buttons make the "click" when pressed so it seems they are put together properly.


    Could it be a fuse issue? Wiring issue? All buttons worked fine prior to trying to switch over to these LED switches. I honestly cannot remember if the passenger side or rear window switches lit up before I messed with it b/c I never really paid attention. However, I have been told they all should light up.

    Thanks
    -Justin

    Pittsburgh - City of Champions...again

    Steelers & Penguins 2009 Champs



  2. #2
    Join Date
    Jun 2005
    Location
    Pittsburgh
    Posts
    1,958

    Default

    any ideas?
    -Justin

    Pittsburgh - City of Champions...again

    Steelers & Penguins 2009 Champs



  3. #3

    Default

    The button(s) is/are not put back properly. Most probably upside down. There were two threads on this recently (a few months ago?).

  4. #4
    Join Date
    Jun 2005
    Location
    Pittsburgh
    Posts
    1,958

    Default

    really? I'll have to search. I'm very rarely in the troubleshooting forum so if they were posted here that's prob why I missed them. I'll have to take a look.

    Edit: per one of the threads i searched and brought up it says the back window switches only light up when they are turned on from the master switch. My back window switches don't light up even when the slider switch on the main board allows them to be wound down. I'll have to see if they are snapped together upside down.

    Still don't get the issue w/ the passenger window switch though. It will not wind up or down nor lights up. And the lock on the passenger locks but does not unlock.
    Last edited by teamSVTour; 02-10-2007 at 03:12 PM.
    -Justin

    Pittsburgh - City of Champions...again

    Steelers & Penguins 2009 Champs



  5. #5

    Default

    If you had given me a few more minutes, I would have edited my previous post.
    Now I have no choice but to increase my post count.
    Read this.
    http://www.contour.org/ubbthreads/showflat.php?Cat=&Board=trouble&Number=1241307&For um=trouble&Words=window%20switch&Match=And&Searchp age=0&Limit=25&Old=allposts&Main=1241162&Search=tr ue#Post1241307

    There was another thread in the new forums. I'll post if I find it.

  6. #6
    Join Date
    Jun 2005
    Location
    Pittsburgh
    Posts
    1,958

    Default

    UPDATE:

    It was a little warmer today so I took another crack at my switches. All the switches functionally work now i.e. meaning all buttons unlock/lock or wind up/wind down like they are supposed to. So that part is fixed.

    BUT....I still have issues w/ the LED lighting up in the window switches. I tested all the window switches by plugging them into the passenger lock/unlock socket and they all do in fact light up. So the LED's in all switches DO work. It seems it is passenger window socket as well as the both back seat sockets that are causing the problem.

    So to me it seems it has to be 1 of 2 things: a) there is not a power wire to light the LED in the passenger window socket and both the rear passenger sockets or b) a blown fuse. I checked all the cabin fuses and all are ok (have not checked the under the hood fuse box yet) so what could the issue be? I could have sworn these window sockets are wired to light up
    -Justin

    Pittsburgh - City of Champions...again

    Steelers & Penguins 2009 Champs



  7. #7

    Default

    Quote Originally Posted by teamSVTour View Post
    ... I could have sworn these window sockets are wired to light up
    Yes, they are. The "bulbs" are blown. You have to get the "bulbs with wires" from the dealer or solder in some LEDs yourself. Or sell the car as is.

  8. #8
    Join Date
    Jun 2005
    Location
    Pittsburgh
    Posts
    1,958

    Default

    Quote Originally Posted by Tony2005 View Post
    Yes, they are. The "bulbs" are blown. You have to get the "bulbs with wires" from the dealer or solder in some LEDs yourself. Or sell the car as is.
    Umm I don't think you follow what I was saying .

    I have LED's soldered into every switch. Only the passenger window switch and both rear window switches do not light up when plugged into their respective socket. The driver main switch and the lock/unlock on both the driver and passenger light up. I tested all the window switches that did not light by sticking them in the passenger side lock/unlock socket and they all lit up which means ALL the LED's are fine. However it's when I plug these window switches where they are supposed to go they do not light up.

    So it seems to me it has something to do w/ the window sockets.

    Where did you get the impression I was selling my car?
    -Justin

    Pittsburgh - City of Champions...again

    Steelers & Penguins 2009 Champs



  9. #9

    Default

    Quote Originally Posted by teamSVTour View Post
    Umm I don't think you follow what I was saying .

    ..................Where did you get the impression I was selling my car?
    I need a new prescription.

    I misread your signature.

  10. #10
    Join Date
    Aug 2000
    Location
    Omaha, NE.
    Posts
    828

    Default

    So just so I understand correctly, when you put the window switches in the rear doors do they operate the window or not? I had a similar problem on mine also but i found out that it was due to the master switch. That little switch that controls weather or not to allow the rear windows to roll down by the control of the rear switches was not put back together correctly and is a pian in the a$$. Also when this switch is turned on it does not let the rear switches to light up neither. Thats the only thing I can think of what the problem would be.
    Quote Originally Posted by Davo
    Good work, Dave. You're definitely the #1 interior guy around these parts; always innovating.
    RedlineGoods Shifter Boots:5% Discount

+ Reply to Thread
Page 1 of 2
1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts