+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 10 of 13

Thread: 1998 Contour SE Stalls in IDLE.

  1. #1

    Default 1998 Contour SE Stalls in IDLE.

    Hello all,

    I have a 1998 Contour SE, which stalls when trying to idle, it also runs very rough when slowing to a stop sign as if it wants to stall.

    I had a lincoln before and the same problem turned out to be a dirty IACV, which i took off, cleaned and away i went. On my contour when these symtoms started i took it to the mechanic cause I could not remove the IACV on this car, too tight a space.

    My mechanic checked the error codes which came up "Bank 1 too lean" and "Bank 2 too lean". He tested the IACV and he said it was stuck in the open position. He replaced it and everything seemed fine for about a day, then the stalling in idle came back. I just took it in again today and my mechanic scanned the codes, "Bank 1 too lean" and "Bank 2 too lean", he removed the new iacv and it tested faulty too, so he had it exchanged for a new one, which seems to already be acting up 3 hours later, and the "Check Engine" light is on again.

    Is there something that could be causing the IACV to keep blowing? Is there anything else I should be checking???

    Thanks in advance,
    Ryan Halstead
    1998 Ford Contour SE
    "106,000 kms"

  2. #2

    Default

    Welcome , check the wiring from IAC valve and Throttle Position Sensor.

  3. #3

    Default

    Quote Originally Posted by Tony2005 View Post
    Welcome , check the wiring from IAC valve and Throttle Position Sensor.
    Hey Tony, Thanks for the reply. The connection going into the iac looks good, should i be tracing it back to somewhere? And which connection is the TPS, I have read about the TPS but not very familiar with it. Is it located on the throttle body somewhere?
    Ryan Halstead
    1998 Ford Contour SE
    "106,000 kms"

  4. #4

    Default

    i have traced the wiring from the iac back to the engine harness with no visible or physical problems. I have cleaned the MAF sensor as well. It dosent like to idle at all. When you cold start it it will go to 2k revs then drop like a rock to 0 and stall. when its warm it will make a half assed attempt at staying idle before stalling. When at a stop sign it runs real rough as if it wants to stall, but keeping the rev's up above 1000 smooths things right out. Cant i just manually set the idle rev's higher (like above 1000)? This would fix all my problems. The IAC has been replaced twice and i cant replace it again just to have it do the same. Any other suggestions would be greatly appreciated.
    Ryan Halstead
    1998 Ford Contour SE
    "106,000 kms"

  5. #5
    Join Date
    Sep 2000
    Location
    Thousand Oaks, California, USA
    Posts
    7,295

    Default

    Look for a vacuum leak. That would explain both the codes and the symptoms.
    Jim Johnson
    98 SVT
    03 Escape Limited
    10 Fusion Sport

  6. #6

    Default

    so to check for a vacuum leak, i need to get a can of carb cleaner and spray all around the hoses? im waiting to hear the idle go up???
    Ryan Halstead
    1998 Ford Contour SE
    "106,000 kms"

  7. #7
    Join Date
    Sep 2000
    Location
    Thousand Oaks, California, USA
    Posts
    7,295

    Default

    That's one way. Also check intake manifold gaskets and injector "O" rings.
    Jim Johnson
    98 SVT
    03 Escape Limited
    10 Fusion Sport

  8. #8

    Default

    "so to check for a vacuum leak, i need to get a can of carb cleaner and spray all around the hoses?"
    Hoses and gaskets (intake manifolds)

    "im waiting to hear the idle go up???"

    or down

  9. #9
    Join Date
    Sep 2000
    Location
    Louisville, Ky
    Posts
    9,582

    Default

    I would think if the IAC was stuck open the engine would rev up. I too vote for a vacuum leak.
    Jim Hahn
    1999 Tropic Green SVT Contour
    1996 T-Red Contour SE Reborn 4/6/04 Sold
    3.0L swap and Arizona Dyno Chip Turbo Kit
    364 whp, 410 wtq @ 4,700 rpm

  10. #10

    Default

    Quote Originally Posted by Tony2005 View Post
    "so to check for a vacuum leak, i need to get a can of carb cleaner and spray all around the hoses?"
    Hoses and gaskets (intake manifolds)

    "im waiting to hear the idle go up???"

    or down
    I took out my carb cleaner today and sprayed all around the engine compartment, didnt notice idle change at all. I then turned the car off, unhooked the IAC and then started the engine, it died immediatley, when hooking the IAC back up it started to sputted and tried to idle before stalling. Does this mean the IAC is working??? If so, i need more suggestions of things to try.
    Ryan Halstead
    1998 Ford Contour SE
    "106,000 kms"

+ Reply to Thread
Page 1 of 2
1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts