Announcement

Collapse
No announcement yet.

E-brake woes

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by ukfan50 View Post
    Thanks for the tip... So can you still get the kit from Team Ford for that price? Happen to know the contact info for Team Ford? Just trying to save some $ and I appreciate it.
    EDIT-Just called Team Ford & they don't have any kits nor can they even get either cable. So much for saving some $. I'm paying $133 for both cables but at least I can get them I guess?


    I'm only using ford ebrake cables, I've read through some of the threads about the cheaper ones not lasting.
    Thanks for the info! I ended up having all 3 cables replaced with NAPA cables bc Ford can't get them anymore, unless they have them in stock. The tech who replaced them said they are identical (same part # as OEM & identical in every way as far as the way the NAPA cables are manufactured).
    02 Sonic Blue SVT Focus (Build Number 1200 of 4788-Build Date 4/18/2002)-Bought 10/2011
    00 T-Red SVT Contour-(Build Number 1089 of 2150-Build Date: 12/23/99)-SOLD 10/2011

    Comment


    • #47
      so there are no conclusions regarding the handle cable. not the rear piece? also, i dont see how these heatshields come off. theyre threaded downward. it looks like they would absolutely have to come off to get the cable thru.
      98 3l SC #2354
      98 3l #4594

      Comment


      • #48
        Anyone have a clue where I could find the equalizer and handle cable? The drivers side cable slipped off and I guess pulled a larger hole in the equalizer and the only way I'm able to hold it on is warping the whole equalizer. I rather have the whole thing replaced.
        1990 Nissan 240SX RWD FTW
        1995 Contour SE MTX WENT BOOM! Bye bye diff.
        1979 Chevrolet Camaro Berlinetta 355ci/TH350/Posi
        1996 Contour GL MTX SOLD
        1989 Oldsmobile Cutlass Ciera 3.3L 192k miles SOLD :(

        Comment


        • #49
          This thread is more about replacing the cable than adjusting it, but can anyone tell me how to adjust it? Mine is dragging when i drive
          99 Contour SE, Zetec ATX; Razzi Kitted, Custom House of Kolor paint, Acquired 12/06 RIP 11/09
          '99 SVT #2243 Black/Tan

          Comment


          • #50
            They are supposed to be self adjusting. If one side is dragging either the cable is rusty and not releasing or the caliper its self is sticking and should be rebuilt or replaced.
            98 SVT #81 silfro

            Aircougar Performance

            Comment


            • #51
              Originally posted by Murtaza View Post
              Anyone have a clue where I could find the equalizer and handle cable? The drivers side cable slipped off and I guess pulled a larger hole in the equalizer and the only way I'm able to hold it on is warping the whole equalizer. I rather have the whole thing replaced.
              Either a junk yard or a Ford dealer.
              98 SVT #81 silfro

              Aircougar Performance

              Comment


              • #52
                Could a faulty cable cause some kick back in my brake pedal? It seems like every now an then I can hear a noise coming from around there and I feel my brake pedal kick and move. I've replaced front rotors & pads. Rear shoes and wheel cylinder. I thought by replacing the cylinder this would help, but it didn't. It still happens occasionally. After I had a guy help me install the wheel cylinder he said, "Don't use your parking brake, looks like the cable is bad". I'm supposed to bring it back to him. Could this be causing a pulsating motion in the brake pedal? It only happens about twice a day while driving the car?

                Comment


                • #53
                  Originally posted by raftingdon2 View Post
                  Could a faulty cable cause some kick back in my brake pedal? It seems like every now an then I can hear a noise coming from around there and I feel my brake pedal kick and move. I've replaced front rotors & pads. Rear shoes and wheel cylinder. I thought by replacing the cylinder this would help, but it didn't. It still happens occasionally. After I had a guy help me install the wheel cylinder he said, "Don't use your parking brake, looks like the cable is bad". I'm supposed to bring it back to him. Could this be causing a pulsating motion in the brake pedal? It only happens about twice a day while driving the car?
                  This question in one thread would have bean good ,but while I'm here another thought comes to mind .Are the caliper retainer springs being used
                  http://www.contour.org/ceg-vb/showth...aliper+springs
                  read this link
                  http://www.youtube.com/watch?v=AfwmpBdZHN0
                  watch this video and note the spring is on wrong

                  Comment


                  • #54
                    Soo while test driving a contour svt the guy i was in the car with said oh yeah the e brake doesn't work and at 45mph pulled the handle up....i heard nothing and it looked like the handle gave him zero tension....

                    Comment

                    Working...
                    X